Author Topic: Instrument Panel  (Read 973 times)

Simon

  • Newbie
  • *
  • Posts: 4
  • Member
    • View Profile
Instrument Panel
« on: January 27, 2016, 08:28:57 AM »
I am having problems with my instrument panel. The tachometer is not working. The warning lights are fully functional and I am getting intermittent readings from the LCD. Does anyone have any advice / suggestions as to how the problem may be resolved? Thanks.

Darthmaul

  • Newbie
  • *
  • Posts: 4
  • Member
    • View Profile
Re: Instrument Panel
« Reply #1 on: January 27, 2016, 05:01:54 PM »
Hi Simon,

I have the same problem last year. Went out for a ride and the Rev meter suddenly stop working, but the lcd display all good.

Could be your speed sensor kaput. Unfortunately the MH900e speed sensor is no longer available. But good things is, you can use the speed sensor from other Ducati models. I m not sure which model that my mechanic use.

Hope that helps.


Simon

  • Newbie
  • *
  • Posts: 4
  • Member
    • View Profile
Re: Instrument Panel
« Reply #2 on: January 29, 2016, 10:34:48 PM »
Thank you very much for the suggestion Darthmaul. I shall try to source a speed sensor and see if this resolves the issue.

L4V

  • Newbie
  • *
  • Posts: 34
  • Member
    • View Profile
Re: Instrument Panel
« Reply #3 on: April 26, 2017, 08:59:55 AM »
Anyone know how to break the code WRT the instrument panel?
Mine will not respond to instructions listed in the manual.
It is stuck on KPH, cannot change the time, etc.
I have pulled the forward most 30 amp fuse and reinstalled, but no change.
Thank you for any information.
.
Don R.
A smooth sea never made a good sailor.